Forum

Please note that you can subscribe to the individual forums. A subscription for news only covers the news.

Notifications
Clear all

FTP is not working in 4.0  

   RSS

0

I am using the same settings for ftp as in 3.4.

The part seems to be rewritten because the log in the report is completely different. The upload of the status is working. 
But the clothes.txt file is not uploaded and the is an error in downloading the script.

 

we 29 08:03:41 FTP list directory
we 29 08:03:41 FTP status: Starting FTP transfer
we 29 08:03:41 FTP status: Transfer complete
we 29 08:03:42 FTP upload of vm3stat.vmt to vm3stat.vmt
we 29 08:03:42 FTP status: Starting FTP transfer
we 29 08:03:42 FTP status: Transfer complete
we 29 08:03:42 FTP - Transfer complete
we 29 08:03:42 FTP error: No FTP list parsers have been registered.
we 29 08:03:42 FTP disconnecting
we 29 08:03:42 FTP status: Disconnecting.
we 29 08:03:42 FTP disconnected
we 29 08:03:42 FTP - Goodbye.
we 29 08:03:42 FTP status: Disconnected.

2 Answers
0

The ftp part, as well as the mail part, is rewritten in 4.0. The routines I used in 3.4 are very old. Now I use some newer libraries (Indy). 

I will look into it. 

0

I googled this, and I expect it has to do with different ftp servers, or different settings on those. 

I did some changes in beta 3, that I hope will solve the problem. I cannot test it myself, as it has always worked on my own server. 

If the problem is still there, can you please send me the new report made with 4.0 beta 3. It has some added information. Remember to have FtpLog=1.

Sven