Forum

Please note that you can subscribe to the individual forums. A subscription for news only covers the news.

Can't start the app...
 
Notifications
Clear all

Can't start the application. Error on start up attempt

10 Posts
2 Users
1 Likes
1,122 Views
0
Topic starter

Hi there!

When I try to open the application I recieve the following error.

Topic Tags
bug
10 Answers
1

Something is wrong with your status file, vm3stat.vms. If you are not running a script for real, then just delete the file and you will start on a fresh.

If you have been running the script for some time, you should have backup called vm3stat.vms.bak. Rename vm3stat.vms  to something else and the rename vm3stat.vms.bak to vm3stat.vms. This will set you back to last successful start of VM, but you will not have lost everything.

Sven

 

0
Topic starter

Hey, thanks for the answer!

Just to clarify, I recieved this error after a fresh download of the application, and selected the demo file to start with. I have never used it before.

I added the files as I have them on my pc currently as attachment

0

That's what I expected. There must be a file called vm3stat in the same folder as the program. Delete that file, and you should be able to start again. Somehow, it must have been corrupted.

Did you extract the files from the zip file? Windows can open a zip file as if it is a folder. If you tried to start the program from within a zip file, it will give problems.

Sven

0
Topic starter

I added a screenshot of the folder to my previous post to indeed make sure there isn't anything in there i'm just to blind to see. The screenshot contains everything that is currently in the folder. As I have never used the program before, there is no vm3stat as of yet. The state of the folder is exactly how I extracted it from the zip file.

And as you can probably make out from it as well, I have extracted the zip file to my Downloads folder and am attempting to run it from there.

0

Strange! I have never seen this before.

When you start the program, does it show a screen where it asks you to select a script. Like the picture I am attaching.

Which operating system do you use?

0
Topic starter

Yes, it indeed asks me which script I wish to use, so far so good, but then when I select it the error appears.

So, I don't know which language you use to write the application, but looking at the error my first instinct would be that it's trying to generate a timestamp to place in the report, however upon retrieving the current time from my system it is recieving it in an format it does not expect, which would make sense as I assume you are using the American notation* ( MM-DD-YYYY ) while I am in EU and my datetime is formatted as ( DD-MM-YYYY ).

Or well, looking at the error it seems it's formatted as "YYYY-MM-DD HH-MM-SS"
But I imagine it might be different from the American annotation.

I use Windows 10, 64 bit.

*I just noticed your profile says your in EU/paris timezone so this might not actually hold up

This post was modified 2 years ago 3 times by HereticAngel
0

You are right! Well, almost right. I am in EU myself, using the European date format. The problem lies in the time separator. You use a dot (.), where I (and so far everybody else who have run the program) uses colon(:).

I generate the problem myself. I convert current timestamp to a string format, and later reads it back. But for converting to the string, I use a system function, that generates dot for you and colon for me. However, when I convert it back, I use a home-made routine, that expects colons.

I can fix that.

Sven

0

P.S. VM is coded in Delphi.

0
Topic starter

Ah Delphi, cool!

And yeah the dot notation indeed seems to be the issue. Using dots rather than a colon is a Finnish thing, I don't really know why that is to be honest. If I indeed change the regional format to use colons VM starts normally.

I suppose while I imagine this is a very niche issue it might indeed be worthwhile to add in a check for it.

Either way thanks for your time and your hard work!

0

I will fix it. It's a too foolish an error to have. Actually, I didn't know there existed such a thing as time separation character. But of course the program must be able to handle it. I do handle the different date formats.

Now that your immediately problem is solved, I won't hurry too much with a solution. But it will be in the next release.